Weird keyboard locks in IntelliJ IDEA (delete & arrow keys, etc.)



While working in IntelliJ IDEA, the keyboard occasionally locks in a way that delete or < > ^ keys don't work properly anymore, in a way that delete doesn't do anything anymore, and the arrow keys scroll the entire source code / editor section.

I don't know if I am accidentially some kind of shortcut, but the only way I can get it back to normal again is closing and re-opening the IDE, which is annoying of course.

I'm on Mac OS X Lion, latest IntelliJ IDEA CE (11.1.1), but also had it before with the previous versions.

Mathias Conradt

Posted 2012-05-03T11:30:16.690

Reputation: 22 213

On Montain Lion, and with latest IDEA (12.1.2) and still happens to me 2-3 times per week... – Adagios – 2013-05-02T10:56:20.240

There seems to be a new bug open at JetBrains that's relevant to this.

– Adagios – 2013-05-02T11:09:26.957

Here is a workaround to this issue – Camilo Silva – 2014-12-07T16:20:58.370



Check idea.log (Help | Reveal Log in ...) for exceptions. If you see PSI/document inconsistency before reparse there, then you are probably affected by this bug.

If there are other exceptions not related to this bug, please send the log to JetBrains technical support.


Posted 2012-05-03T11:30:16.690

Reputation: 268 431

Yes, I see this in the log, and it's also still in v11.1.2. I haven't tried the latest EAP though yet. – Mathias Conradt – 2012-07-03T03:20:55.013

It's fixed in 11.1.3 EAP. – CrazyCoder – 2012-07-03T17:15:17.330


This answer on worked for me:

ibus-daemon -rd


Posted 2012-05-03T11:30:16.690

Reputation: 1 251

5This worked for me. However it set the keyboard layout to US. I used the following to set the keyboard to UK (you will need to change this to whatever your keyboard is): ibus-daemon -rd sleep 0.25 setxkbmap gb Not sure why a delay is required, but without it the keyboard remains mapped to US – Matt Innes – 2014-11-07T10:04:07.027

1Using fish-shell ibus-daemon -rd; and sleep 0.25; and setxkbmap gb did the trick for me on Ubuntu 14.04 – Markus – 2015-06-24T14:26:47.583


Just turn off Vim Emulator from Tools like this picture:

enter image description here


Posted 2012-05-03T11:30:16.690

Reputation: 1 248


I am new to IntelliJ, and had the same problem of deleting by delete. But I just realised that IntelliJ is actually mimicing the keys in Vim.

For example, when some text is highlighted, pressing d deletes the text, pressing y copies (yanks) it, pressing p pastes (puts) it, and pressing i enters the editting (insert) mode.

For navigation, Ctrl+f navigates to the next screen, Ctrl+b navigates to the previous screen, and Shift+g navigates to the end of the file.

All are same as in Vim.

Sophia Feng

Posted 2012-05-03T11:30:16.690

Reputation: 644

9No worries, I've just figured it out. There's an option under Tools call Vim Emulator, uncheck this and it will fix the issue. – alsobubbly – 2015-04-22T10:03:38.693


I faced same issue,


IDEA 14.1.4 on Ubuntu Gnome 15.04

Solution :

I work with default keymaps, but some reason default keymap was not working. Hence I removed 'IdeaVim' plugin and restarted the IDE, everything works fine now. File > Settings > Plugins and look for the plugins.

Thamme Gowda

Posted 2012-05-03T11:30:16.690

Reputation: 6 272


I have the same issue periodically, which is a pain because IntelliJ takes so long to load in the first place, then I need to close it and start all over again!

I don't have "PSI" anywhere in my IntelliJ logs. I'll be sending my logs off to IntelliJ; hopefully they can fix this ASAP as it is a major time waster!

Other things I've tried:

  • Changing the current keymap - arrow keys don't work in any keymaps
  • Closing and reopening just the project - issue persists until IntelliJ itself is closed and reopened.
  • Trying other keys - It seems like Ctrl and Command are completely ignored by the IDE once it gets in this state. Of course, all the text entry keys still work, so you can type, just can't change cursor position using anything but the mouse and menu bar. In a pinch, one could work like this for a short period of time, but that would entail a significant masochist streak!

Tom Dibble

Posted 2012-05-03T11:30:16.690

Reputation: 95

I'm on 11.1.2 meanwhile and as far as I remember, it seems to have gotten better, can't really recall whether I had this issue since the update, but might be worth to update if you haven't. Which IDEA version are you using? – Mathias Conradt – 2012-07-03T03:12:29.120

(However, the mentioned bug below doesn't seem to be fixed with 11.1.2 either, still some problems, but I haven't checked the EAP as of Jun 22 yet).

– Mathias Conradt – 2012-07-03T03:19:20.693

I have the same issue, with IntelliJ 12.0.1 Build UI-123.84. I have no "inconsistency" text in the log file. – David Portabella – 2013-01-14T14:58:22.547

1I had the same issue in 12.0.2 on Windows 7, also no "inconsistency" in the log file. I tried changing my Keymap settings, and once I set them back to "Default" everything worked again. – findango – 2013-01-31T22:02:07.823

Same issue on Lion 10.7.5, IntelliJ build IU-123.169 (version 12.0.4). The delete key just stops working for no apparent reason. – Tommy Knowlton – 2013-02-22T20:51:23.057

I'm facing the same issue on IntelliJ 135.1230 (13.1.5) on Fedora 20 (linux). Restarting the intellij fixes it temporarily. But it's really annoying... – Sriram – 2014-10-24T16:14:08.027


There is a an open issue in jetbrains youtrack for intellij idea that recommend two solutions:

  1. Keyboard input may be unlocked by restarting IBus daemon ("ibus-daemon -rd" from a console).
  2. IBus can be disabled for IDEA by unsetting env. variable XMODIFIERS (e.g. "XMODIFIERS="), but ability to input national characters in IDEA will be lost.

I have used the second one and fixed my problem.

Saeed Zarinfam

Posted 2012-05-03T11:30:16.690

Reputation: 5 871


You may need to update your plugins. They can cause strange behavior if they are out of date.


Posted 2012-05-03T11:30:16.690

Reputation: 2 829


If you do ibus restart, you'll get a qwerty keyboard. For french users, you can do :

ibus restart; sleep 1; ibus engine xkb:fr::fra 

I suppose you can change fr::fra by ru or us:dvorak:eng

Nicolas Zozol

Posted 2012-05-03T11:30:16.690

Reputation: 4 801


I had the same issue when upgrading to IntelliJ 14.1.4. If you have the IdeaVim plug-in installed, try disabling it. That worked for me. Reference


Posted 2012-05-03T11:30:16.690

Reputation: 1 234


In my case backspace didn't work but only in terminal. I fixed it by going

Preferences -> Terminal -> Check "Override IDE shortcuts"

Piotr Korlaga

Posted 2012-05-03T11:30:16.690

Reputation: 1 435


Same problem for me today. My solution was to unplug and plugin the usb keyboard on my MacBook. Hope it helps.


Posted 2012-05-03T11:30:16.690

Reputation: 2 821